aboutsummaryrefslogtreecommitdiffstats
path: root/consolekit-git
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2013-06-09 11:09:22 +0200
committerMattias Andrée <maandree@operamail.com>2013-06-09 11:09:22 +0200
commit7333857bad62d50cca7a70b759aecb10cf6097d1 (patch)
tree3eadd9f2cd12c77f49a181efb40d7ebb3ec37c6e /consolekit-git
parentadd bluez-libs as makedeps to qtsixa (diff)
downloadaur-packages-7333857bad62d50cca7a70b759aecb10cf6097d1.tar.gz
aur-packages-7333857bad62d50cca7a70b759aecb10cf6097d1.tar.bz2
aur-packages-7333857bad62d50cca7a70b759aecb10cf6097d1.tar.xz
adopt consolekit-git
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to '')
-rw-r--r--consolekit-git/PKGBUILD59
-rw-r--r--consolekit-git/consolekit.logrotate5
-rw-r--r--consolekit-git/consolekit.tmpfiles.conf1
-rw-r--r--consolekit-git/pam-foreground-compat.ck16
-rwxr-xr-xconsolekit-git/watch19
5 files changed, 100 insertions, 0 deletions
diff --git a/consolekit-git/PKGBUILD b/consolekit-git/PKGBUILD
new file mode 100644
index 0000000..2520823
--- /dev/null
+++ b/consolekit-git/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: onestep_ua <onestep@ukr.net>
+
+pkgname=consolekit-git
+pkgver=393.9be71ac
+pkgrel=1
+epoch=1
+pkgdesc="A framework for defining and tracking users, login sessions, and seats"
+arch=('i686' 'x86_64')
+url="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+license=('GPL')
+depends=('polkit' 'zlib' 'libx11' 'dbus-glib')
+makedepends=('git' 'pkgconfig' 'xmlto' 'docbook-xsl')
+replaces=('consolekit')
+provides=('consolekit')
+conflicts=('consolekit')
+options=(!libtool)
+source=(git+git://anongit.freedesktop.org/ConsoleKit \
+ pam-foreground-compat.ck consolekit.logrotate consolekit.tmpfiles.conf)
+md5sums=('SKIP'
+ 'a8a4de71d9b0549b8143e5f6c2a36fc7'
+ '6fefa451d9fe2fc6d6269629d3529793'
+ '8c5a8059db515d40fae1379daf084094')
+
+pkgver() {
+ cd "$srcdir/ConsoleKit"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/ConsoleKit"
+
+ ./autogen.sh --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/ConsoleKit \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --enable-pam-module \
+ --with-pam-module-dir=/usr/lib/security \
+ --enable-docbook-docs \
+ --enable-udev-acl
+ make
+}
+
+package() {
+ cd "$srcdir/ConsoleKit"
+ make DESTDIR="$pkgdir" install
+ install -m755 "$srcdir/pam-foreground-compat.ck" "$pkgdir/usr/lib/ConsoleKit/run-session.d/"
+
+ # install the logrotate config
+ install -D -m644 "$srcdir/consolekit.logrotate" "$pkgdir/etc/logrotate.d/consolekit"
+
+ install -D -m644 "$srcdir/consolekit.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/consolekit.conf"
+
+ rm -rf "$pkgdir/var/run"
+}
diff --git a/consolekit-git/consolekit.logrotate b/consolekit-git/consolekit.logrotate
new file mode 100644
index 0000000..7c5346e
--- /dev/null
+++ b/consolekit-git/consolekit.logrotate
@@ -0,0 +1,5 @@
+/var/log/ConsoleKit/history {
+ missingok
+ notifempty
+ delaycompress
+}
diff --git a/consolekit-git/consolekit.tmpfiles.conf b/consolekit-git/consolekit.tmpfiles.conf
new file mode 100644
index 0000000..4ec1251
--- /dev/null
+++ b/consolekit-git/consolekit.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/ConsoleKit 0755 - - -
diff --git a/consolekit-git/pam-foreground-compat.ck b/consolekit-git/pam-foreground-compat.ck
new file mode 100644
index 0000000..7f6b122
--- /dev/null
+++ b/consolekit-git/pam-foreground-compat.ck
@@ -0,0 +1,16 @@
+#!/bin/sh
+TAGDIR=/var/run/console
+
+[ -n "$CK_SESSION_USER_UID" ] || exit 1
+
+TAGFILE="$TAGDIR/`getent passwd $CK_SESSION_USER_UID | cut -f 1 -d:`"
+
+if [ "$1" = "session_added" ]; then
+ mkdir -p "$TAGDIR"
+ echo "$CK_SESSION_ID" >> "$TAGFILE"
+fi
+
+if [ "$1" = "session_removed" ] && [ -e "$TAGFILE" ]; then
+ sed -i "\%^$CK_SESSION_ID\$%d" "$TAGFILE"
+ [ -s "$TAGFILE" ] || rm -f "$TAGFILE"
+fi
diff --git a/consolekit-git/watch b/consolekit-git/watch
new file mode 100755
index 0000000..d57693b
--- /dev/null
+++ b/consolekit-git/watch
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+wget 'http://cgit.freedesktop.org/ConsoleKit' -O - 2>/dev/null | grep -Po '\.tar.+>ConsoleKit-.+\.tar' | head -n 1 > release
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ md5sum release > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'consolekit-git'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'consolekit-git (unfetchable)'
+fi
+