aboutsummaryrefslogtreecommitdiffstats
path: root/alsause/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2024-06-01 14:37:01 +0200
committerMattias Andrée <maandree@kth.se>2024-06-01 14:37:01 +0200
commit7b9f54b9094c094e1131d0784eb680e9f56c2114 (patch)
treeecf446a63fc47a9c4095dc6250682e9bb7be80e8 /alsause/PKGBUILD
parentUpdate python-bus to version 3.1.4 (diff)
downloadaur-packages-7b9f54b9094c094e1131d0784eb680e9f56c2114.tar.gz
aur-packages-7b9f54b9094c094e1131d0784eb680e9f56c2114.tar.bz2
aur-packages-7b9f54b9094c094e1131d0784eb680e9f56c2114.tar.xz
Add alsause
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--alsause/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/alsause/PKGBUILD b/alsause/PKGBUILD
new file mode 100644
index 0000000..e8fdc32
--- /dev/null
+++ b/alsause/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=alsause
+pkgver=1.0
+pkgrel=1
+pkgdesc="Set default ALSA PCM device"
+url='https://codeberg.org/maandree/alsause'
+arch=(i686 x86_64)
+license=('custom:ISC')
+depends=(libsimple libasound.so)
+makedepends=(libsimple libasound.so)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha512sums=(e33c60915fcd8b54c13f685ed588480a27c7ce691ae1775eab639855e03561b7b00713c8759ade5eaeb5565c9a706043c90500fb869d8752381fbdc4a175a545)
+
+build () {
+ cd "$srcdir/alsause"
+ make PREFIX=/usr
+}
+
+package () {
+ cd "$srcdir/alsause"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" post-install
+}