aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2014-05-24 02:03:54 +0200
committerMattias Andrée <maandree@operamail.com>2014-05-24 02:03:54 +0200
commitda005320cacd196c7db9bb2d0fc4b16ba6efd79f (patch)
treebbcad7a9b00ccb8579dee50dc2ae5d9bcec361b4
parentadd watch script for qtchess (diff)
downloadaur-packages-da005320cacd196c7db9bb2d0fc4b16ba6efd79f.tar.gz
aur-packages-da005320cacd196c7db9bb2d0fc4b16ba6efd79f.tar.bz2
aur-packages-da005320cacd196c7db9bb2d0fc4b16ba6efd79f.tar.xz
add xorg-server-hwcursor-gamma
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to '')
-rw-r--r--xorg-server-hwcursor-gamma/.gitignore2
-rw-r--r--xorg-server-hwcursor-gamma/0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch55
-rw-r--r--xorg-server-hwcursor-gamma/0002-Fix-for-full-and-semi-transparency-under-negative-im.patch86
-rw-r--r--xorg-server-hwcursor-gamma/0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch54
-rw-r--r--xorg-server-hwcursor-gamma/10-quirks.conf10
-rw-r--r--xorg-server-hwcursor-gamma/CVE-2013-6424.diff49
-rw-r--r--xorg-server-hwcursor-gamma/PKGBUILD130
-rw-r--r--xorg-server-hwcursor-gamma/autoconfig-nvidia.patch28
-rw-r--r--xorg-server-hwcursor-gamma/autoconfig-sis.patch21
-rw-r--r--xorg-server-hwcursor-gamma/xvfb-run180
-rw-r--r--xorg-server-hwcursor-gamma/xvfb-run.1282
11 files changed, 897 insertions, 0 deletions
diff --git a/xorg-server-hwcursor-gamma/.gitignore b/xorg-server-hwcursor-gamma/.gitignore
new file mode 100644
index 0000000..a921a8e
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/.gitignore
@@ -0,0 +1,2 @@
+!/CVE-2013-6424.diff
+!/xvfb-run.1
diff --git a/xorg-server-hwcursor-gamma/0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch b/xorg-server-hwcursor-gamma/0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
new file mode 100644
index 0000000..5eeb826
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
@@ -0,0 +1,55 @@
+From e63b5656a6509ece2d5ffb1fb962911519163988 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Mattias=20Andr=C3=A9e?= <maandree@operamail.com>
+Date: Tue, 15 Apr 2014 02:45:25 +0200
+Subject: [PATCH 1/3] When an cursor is set, it is adjusted to use the gamma
+ ramps of the CRTC:s that it is loaded on.
+
+This could be improved to be done in
+`crtc->funcs->load_cursor_argb` with more
+accurate adjustments. But I was not able to
+find where `crtc->funcs->load_cursor_argb`
+is implement.
+
+Additionally, `xf86_reload_cursors` should be
+called when the gamma settings changes. This
+way the cursor's colours are adjusted to use
+the gamma settings directly when the gamma
+is modified rather than the next time its
+image changes.
+---
+ hw/xfree86/modes/xf86Cursors.c | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/hw/xfree86/modes/xf86Cursors.c b/hw/xfree86/modes/xf86Cursors.c
+index 2b0db34..3cb499f 100644
+--- a/hw/xfree86/modes/xf86Cursors.c
++++ b/hw/xfree86/modes/xf86Cursors.c
+@@ -242,6 +242,12 @@ xf86_crtc_convert_cursor_to_argb(xf86CrtcPtr crtc, unsigned char *src)
+ }
+ else
+ bits = 0;
++ if (crtc->gamma_red && crtc->gamma_size == 256) {
++ bits = (bits & 0xFF000000) |
++ ((crtc->gamma_red[(bits >> 16) & 255] >> 8) << 16) |
++ (crtc->gamma_green[(bits >> 8) & 255] & 0xFF00) |
++ (crtc->gamma_blue[bits & 255] >> 8);
++ }
+ cursor_image[y * cursor_info->MaxWidth + x] = bits;
+ }
+ crtc->funcs->load_cursor_argb(crtc, cursor_image);
+@@ -541,6 +547,12 @@ xf86_crtc_load_cursor_argb(xf86CrtcPtr crtc, CursorPtr cursor)
+ bits = cursor_source[yin * source_width + xin];
+ else
+ bits = 0;
++ if (crtc->gamma_red && crtc->gamma_size == 256) {
++ bits = (bits & 0xFF000000) |
++ ((crtc->gamma_red[(bits >> 16) & 255] >> 8) << 16) |
++ (crtc->gamma_green[(bits >> 8) & 255] & 0xFF00) |
++ (crtc->gamma_blue[bits & 255] >> 8);
++ }
+ cursor_image[y * image_width + x] = bits;
+ }
+
+--
+1.9.2
+
diff --git a/xorg-server-hwcursor-gamma/0002-Fix-for-full-and-semi-transparency-under-negative-im.patch b/xorg-server-hwcursor-gamma/0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
new file mode 100644
index 0000000..3a41a81
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
@@ -0,0 +1,86 @@
+From 7b34ab1dbeb4a1e29d7475af65f42e1cb6f60de8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Mattias=20Andr=C3=A9e?= <maandree@operamail.com>
+Date: Sat, 19 Apr 2014 19:36:05 +0200
+Subject: [PATCH 2/3] Fix for full and semi-transparency under negative image.
+
+---
+ hw/xfree86/modes/xf86Cursors.c | 49 +++++++++++++++++++++++++++++++-----------
+ 1 file changed, 37 insertions(+), 12 deletions(-)
+
+diff --git a/hw/xfree86/modes/xf86Cursors.c b/hw/xfree86/modes/xf86Cursors.c
+index 3cb499f..5afd740 100644
+--- a/hw/xfree86/modes/xf86Cursors.c
++++ b/hw/xfree86/modes/xf86Cursors.c
+@@ -209,6 +209,41 @@ set_bit(CARD8 *image, xf86CursorInfoPtr cursor_info, int x, int y, Bool mask)
+ }
+
+ /*
++ * Remap a cursor pixel according to the gamma ramps
++ */
++static CARD32
++cursor_gamma_correct(xf86CrtcPtr crtc, CARD32 bits)
++{
++ float alpha;
++ CARD32 old_red, new_red;
++ CARD32 old_green, new_green;
++ CARD32 old_blue, new_blue;
++
++ if (!(crtc->gamma_red && crtc->gamma_size == 256))
++ return bits;
++
++ alpha = (float)((bits >> 24) & 255) / 255.f;
++
++ old_red = (bits >> 16) & 255;
++ old_green = (bits >> 8) & 255;
++ old_blue = (bits >> 0) & 255;
++
++ new_red = (crtc->gamma_red [old_red ]) >> 8;
++ new_green = (crtc->gamma_green[old_green]) >> 8;
++ new_blue = (crtc->gamma_blue [old_blue ]) >> 8;
++
++ new_red = new_red * alpha + old_red * (1 - alpha);
++ new_green = new_green * alpha + old_green * (1 - alpha);
++ new_blue = new_blue * alpha + old_blue * (1 - alpha);
++
++ new_red = new_red < 0 ? 0 : new_red > 255 ? 255 : new_red;
++ new_green = new_green < 0 ? 0 : new_green > 255 ? 255 : new_green;
++ new_blue = new_blue < 0 ? 0 : new_blue > 255 ? 255 : new_blue;
++
++ return (bits & 0xFF000000) | (new_red << 16) | (new_green << 8) | (new_blue << 0);
++}
++
++/*
+ * Load a two color cursor into a driver that supports only ARGB cursors
+ */
+ static void
+@@ -242,12 +277,7 @@ xf86_crtc_convert_cursor_to_argb(xf86CrtcPtr crtc, unsigned char *src)
+ }
+ else
+ bits = 0;
+- if (crtc->gamma_red && crtc->gamma_size == 256) {
+- bits = (bits & 0xFF000000) |
+- ((crtc->gamma_red[(bits >> 16) & 255] >> 8) << 16) |
+- (crtc->gamma_green[(bits >> 8) & 255] & 0xFF00) |
+- (crtc->gamma_blue[bits & 255] >> 8);
+- }
++ bits = cursor_gamma_correct(crtc, bits);
+ cursor_image[y * cursor_info->MaxWidth + x] = bits;
+ }
+ crtc->funcs->load_cursor_argb(crtc, cursor_image);
+@@ -547,12 +577,7 @@ xf86_crtc_load_cursor_argb(xf86CrtcPtr crtc, CursorPtr cursor)
+ bits = cursor_source[yin * source_width + xin];
+ else
+ bits = 0;
+- if (crtc->gamma_red && crtc->gamma_size == 256) {
+- bits = (bits & 0xFF000000) |
+- ((crtc->gamma_red[(bits >> 16) & 255] >> 8) << 16) |
+- (crtc->gamma_green[(bits >> 8) & 255] & 0xFF00) |
+- (crtc->gamma_blue[bits & 255] >> 8);
+- }
++ bits = cursor_gamma_correct(crtc, bits);
+ cursor_image[y * image_width + x] = bits;
+ }
+
+--
+1.9.2
+
diff --git a/xorg-server-hwcursor-gamma/0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch b/xorg-server-hwcursor-gamma/0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch
new file mode 100644
index 0000000..35875ec
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch
@@ -0,0 +1,54 @@
+From b167a4d01048fc624fdf95faffa74099e5bd8efb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Mattias=20Andr=C3=A9e?= <maandree@operamail.com>
+Date: Mon, 21 Apr 2014 01:05:35 +0200
+Subject: [PATCH 3/3] Use Harms's suggest: do not use inline if. And fix
+ signness issue: CARD32 is unsigned, which results in that if a value because
+ less than zero it would be incorrectly corrected to be 255 rather than 0.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Mattias Andrée <maandree@operamail.com>
+---
+ hw/xfree86/modes/xf86Cursors.c | 18 +++++++++++-------
+ 1 file changed, 11 insertions(+), 7 deletions(-)
+
+diff --git a/hw/xfree86/modes/xf86Cursors.c b/hw/xfree86/modes/xf86Cursors.c
+index 5afd740..b18b7e6 100644
+--- a/hw/xfree86/modes/xf86Cursors.c
++++ b/hw/xfree86/modes/xf86Cursors.c
+@@ -214,10 +214,10 @@ set_bit(CARD8 *image, xf86CursorInfoPtr cursor_info, int x, int y, Bool mask)
+ static CARD32
+ cursor_gamma_correct(xf86CrtcPtr crtc, CARD32 bits)
+ {
+- float alpha;
+- CARD32 old_red, new_red;
+- CARD32 old_green, new_green;
+- CARD32 old_blue, new_blue;
++ float alpha;
++ int32_t old_red, new_red;
++ int32_t old_green, new_green;
++ int32_t old_blue, new_blue;
+
+ if (!(crtc->gamma_red && crtc->gamma_size == 256))
+ return bits;
+@@ -236,9 +236,13 @@ cursor_gamma_correct(xf86CrtcPtr crtc, CARD32 bits)
+ new_green = new_green * alpha + old_green * (1 - alpha);
+ new_blue = new_blue * alpha + old_blue * (1 - alpha);
+
+- new_red = new_red < 0 ? 0 : new_red > 255 ? 255 : new_red;
+- new_green = new_green < 0 ? 0 : new_green > 255 ? 255 : new_green;
+- new_blue = new_blue < 0 ? 0 : new_blue > 255 ? 255 : new_blue;
++ /* Make sure the floating point operations did not yeild invalid results. */
++ if (new_red < 0x00) new_red = 0x00;
++ if (new_red > 0xFF) new_red = 0xFF;
++ if (new_green < 0x00) new_green = 0x00;
++ if (new_green > 0xFF) new_green = 0xFF;
++ if (new_blue < 0x00) new_blue = 0x00;
++ if (new_blue > 0xFF) new_blue = 0xFF;
+
+ return (bits & 0xFF000000) | (new_red << 16) | (new_green << 8) | (new_blue << 0);
+ }
+--
+1.9.2
+
diff --git a/xorg-server-hwcursor-gamma/10-quirks.conf b/xorg-server-hwcursor-gamma/10-quirks.conf
new file mode 100644
index 0000000..7afad22
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/10-quirks.conf
@@ -0,0 +1,10 @@
+# Collection of quirks and blacklist/whitelists for specific devices.
+
+
+# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
+# http://bugs.freedesktop.org/show_bug.cgi?id=22442
+Section "InputClass"
+ Identifier "ThinkPad HDAPS accelerometer blacklist"
+ MatchProduct "ThinkPad HDAPS accelerometer data"
+ Option "Ignore" "on"
+EndSection
diff --git a/xorg-server-hwcursor-gamma/CVE-2013-6424.diff b/xorg-server-hwcursor-gamma/CVE-2013-6424.diff
new file mode 100644
index 0000000..8c664b6
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/CVE-2013-6424.diff
@@ -0,0 +1,49 @@
+From patchwork Wed Oct 2 13:47:54 2013
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+Subject: exa: only draw valid trapezoids
+From: Maarten Lankhorst <maarten.lankhorst@canonical.com>
+X-Patchwork-Id: 14769
+Message-Id: <524C240A.9010607@canonical.com>
+To: "X.Org Devel List" <xorg-devel@lists.freedesktop.org>
+Date: Wed, 02 Oct 2013 15:47:54 +0200
+
+Fixes freedesktop.org bug https://bugs.freedesktop.org/show_bug.cgi?id=67484
+
+If t->bottom is close to MIN_INT, removing top can wraparound, so do the check properly.
+A similar fix should also be applied to pixman.
+
+Signed-off-by: Maarten Lankhorst <maarten.lankhorst@canonical.com>
+
+---
+
+
+diff --git a/exa/exa_render.c b/exa/exa_render.c
+index 172e2b5..807eeba 100644
+--- a/exa/exa_render.c
++++ b/exa/exa_render.c
+@@ -1141,7 +1141,8 @@ exaTrapezoids(CARD8 op, PicturePtr pSrc, PicturePtr pDst,
+
+ exaPrepareAccess(pPicture->pDrawable, EXA_PREPARE_DEST);
+ for (; ntrap; ntrap--, traps++)
+- (*ps->RasterizeTrapezoid) (pPicture, traps, -bounds.x1, -bounds.y1);
++ if (xTrapezoidValid(traps))
++ (*ps->RasterizeTrapezoid) (pPicture, traps, -bounds.x1, -bounds.y1);
+ exaFinishAccess(pPicture->pDrawable, EXA_PREPARE_DEST);
+
+ xRel = bounds.x1 + xSrc - xDst;
+diff --git a/render/picture.h b/render/picture.h
+index c85353a..fcd6401 100644
+--- a/render/picture.h
++++ b/render/picture.h
+@@ -211,7 +211,7 @@ typedef pixman_fixed_t xFixed;
+ /* whether 't' is a well defined not obviously empty trapezoid */
+ #define xTrapezoidValid(t) ((t)->left.p1.y != (t)->left.p2.y && \
+ (t)->right.p1.y != (t)->right.p2.y && \
+- (int) ((t)->bottom - (t)->top) > 0)
++ ((t)->bottom > (t)->top))
+
+ /*
+ * Standard NTSC luminance conversions:
+
diff --git a/xorg-server-hwcursor-gamma/PKGBUILD b/xorg-server-hwcursor-gamma/PKGBUILD
new file mode 100644
index 0000000..76ffd77
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/PKGBUILD
@@ -0,0 +1,130 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer of the xorg-server package: AndyRTR <andyrtr@archlinux.org>
+# Maintainer of the xorg-server package: Jan de Groot <jgc@archlinux.org>
+
+_pkgname=xorg-server
+pkgname=xorg-server-hwcursor-gamma
+pkgver=1.15.1
+pkgrel=1
+pkgdesc="Xorg X server with patch to apply gamma ramps on hardware cursors"
+depends=(libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence)
+backup=('etc/X11/xorg.conf.d/10-evdev.conf' 'etc/X11/xorg.conf.d/10-quirks.conf')
+provides=('xorg-server' 'X-ABI-VIDEODRV_VERSION=15' 'X-ABI-XINPUT_VERSION=20' 'X-ABI-EXTENSION_VERSION=8.0' 'x-server')
+conflicts=('xorg-server' 'nvidia-utils<=331.20')
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://xorg.freedesktop.org"
+makedepends=('pixman' 'libx11' 'mesa' 'mesa-libgl' 'xf86driproto' 'xcmiscproto' 'xtrans' 'bigreqsproto' 'randrproto'
+ 'inputproto' 'fontsproto' 'videoproto' 'presentproto' 'compositeproto' 'recordproto' 'scrnsaverproto'
+ 'resourceproto' 'xineramaproto' 'libxkbfile' 'libxfont' 'renderproto' 'libpciaccess' 'libxv'
+ 'xf86dgaproto' 'libxmu' 'libxrender' 'libxi' 'dmxproto' 'libxaw' 'libdmx' 'libxtst' 'libxres'
+ 'xorg-xkbcomp' 'xorg-util-macros' 'xorg-font-util' 'glproto' 'dri2proto' 'libgcrypt'
+ 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms' 'dri3proto' 'libxshmfence')
+source=(${url}/releases/individual/xserver/${_pkgname}-${pkgver}.tar.bz2
+ autoconfig-nvidia.patch
+ autoconfig-sis.patch
+ xvfb-run
+ xvfb-run.1
+ 10-quirks.conf
+ CVE-2013-6424.diff
+ 0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
+ 0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
+ 0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch)
+sha256sums=('626db6882602ebe1ff81f7a4231c7ccc6ceb5032f2b5b3954bf749e1567221e2'
+ '66e25f76a7496c429e0aff4b0670f168719bb0ceaeb88c6f2272f2bf3ed21162'
+ 'd027776fac1f7675b0a9ee817502290b1c45f9c09b0f0a6bb058c35f92361e84'
+ 'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
+ '2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
+ '94612f5c0d34a3b7152915c2e285c7b462e9d8e38d3539bd551a339498eac166'
+ '89948993afd4d9aec6a0bdbaf62f494e9956bb77a0386307d497f340a818ff61'
+ 'bea348631dedd66475d84ac2cfe0840f22a80a642b4680d73fead4749e47f055'
+ 'be9169b937b5d0b44f7f05d7c08aaa5f0c1092e128ce261d9cb350f09dfe1fb0'
+ '0a643ae83e03faee0f4db669a33c5b3c99edbba5c86cde2c83962ae536d31081')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ # Use nouveau/nv/nvidia drivers for nvidia devices
+ patch -Np1 -i ../autoconfig-nvidia.patch
+
+ # Use unofficial imedia SiS driver for supported SiS devices
+ patch -Np0 -i ../autoconfig-sis.patch
+
+ # Fix CVE-2013-6424 (FS#38401)
+ patch -Np1 -i ../CVE-2013-6424.diff
+
+ # Apply hardware cursors gamma adjustments patchs
+ patch -Np1 -i ../0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
+ patch -Np1 -i ../0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
+ patch -Np1 -i ../0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch
+}
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ autoreconf -fi
+ ./configure --prefix=/usr \
+ --enable-ipv6 \
+ --enable-dri \
+ --enable-dmx \
+ --enable-xvfb \
+ --enable-xnest \
+ --enable-composite \
+ --enable-xcsecurity \
+ --enable-xorg \
+ --enable-xephyr \
+ --enable-glx-tls \
+ --enable-kdrive \
+ --enable-kdrive-evdev \
+ --enable-kdrive-kbd \
+ --enable-kdrive-mouse \
+ --enable-install-setuid \
+ --enable-config-udev \
+ --disable-config-dbus \
+ --enable-record \
+ --disable-xfbdev \
+ --disable-xfake \
+ --disable-static \
+ --sysconfdir=/etc/X11 \
+ --localstatedir=/var \
+ --with-xkb-path=/usr/share/X11/xkb \
+ --with-xkb-output=/var/lib/xkb \
+ --with-fontrootdir=/usr/share/fonts
+
+# --without-dtrace \
+# --disable-linux-acpi --disable-linux-apm \
+
+ make
+
+ # Disable subdirs for make install rule to make splitting easier
+ sed -e 's/^DMX_SUBDIRS =.*/DMX_SUBDIRS =/' \
+ -e 's/^XVFB_SUBDIRS =.*/XVFB_SUBDIRS =/' \
+ -e 's/^XNEST_SUBDIRS =.*/XNEST_SUBDIRS = /' \
+ -e 's/^KDRIVE_SUBDIRS =.*/KDRIVE_SUBDIRS =/' \
+ -i hw/Makefile
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/etc/X11"
+ mv "${pkgdir}/usr/share/X11/xorg.conf.d" "${pkgdir}/etc/X11/"
+ install -m644 "${srcdir}/10-quirks.conf" "${pkgdir}/etc/X11/xorg.conf.d/"
+
+ rmdir "${pkgdir}/usr/share/X11"
+
+ # Needed for non-mesa drivers, libgl will restore it
+ mv "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.so" \
+ "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.xorg"
+
+ rm -rf "${pkgdir}/var"
+
+ rm -f "${pkgdir}/usr/share/man/man1/Xserver.1"
+ rm -f "${pkgdir}/usr/lib/xorg/protocol.txt"
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server"
+ ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server/COPYING"
+
+ rm -rf "${pkgdir}/usr/lib/pkgconfig"
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/share/aclocal"
+}
diff --git a/xorg-server-hwcursor-gamma/autoconfig-nvidia.patch b/xorg-server-hwcursor-gamma/autoconfig-nvidia.patch
new file mode 100644
index 0000000..6d5220a
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/autoconfig-nvidia.patch
@@ -0,0 +1,28 @@
+diff -Nur xorg-server-1.11.99.902.orig/hw/xfree86/common/xf86pciBus.c xorg-server-1.11.99.902/hw/xfree86/common/xf86pciBus.c
+--- xorg-server-1.11.99.902.orig/hw/xfree86/common/xf86pciBus.c 2012-02-10 10:10:37.583014924 +0000
++++ xorg-server-1.11.99.902/hw/xfree86/common/xf86pciBus.c 2012-02-10 11:16:07.148971317 +0000
+@@ -1144,7 +1144,23 @@
+ int idx = 0;
+
+ #ifdef __linux__
+- driverList[idx++] = "nouveau";
++ switch (dev->device_id)
++ {
++ /* NV1 */
++ case 0x0008:
++ case 0x0009:
++ driverList[idx++] = "vesa";
++ break;
++ /* NV3 */
++ case 0x0018:
++ case 0x0019:
++ driverList[idx++] = "nouveau";
++ break;
++ default:
++ driverList[idx++] = "nouveau";
++ driverList[idx++] = "nvidia";
++ break;
++ }
+ #endif
+ driverList[idx++] = "nv";
+ break;
diff --git a/xorg-server-hwcursor-gamma/autoconfig-sis.patch b/xorg-server-hwcursor-gamma/autoconfig-sis.patch
new file mode 100644
index 0000000..0b50049
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/autoconfig-sis.patch
@@ -0,0 +1,21 @@
+--- hw/xfree86/common/xf86pciBus.c.orig 2011-09-24 10:53:45.421697668 +0000
++++ hw/xfree86/common/xf86pciBus.c 2011-09-24 10:55:56.416250708 +0000
+@@ -1200,9 +1200,15 @@
+ break;
+ }
+ break;
+- case 0x1039:
+- driverList[0] = "sis";
+- break;
++ case 0x1039:
++ switch (dev->device_id)
++ {
++ case 0x6350: case 0x6351:
++ driverList[0] = "sisimedia"; driverList[1] = "sis"; break;
++ default:
++ driverList[0] = "sis"; break;
++ }
++ break;
+ case 0x126f:
+ driverList[0] = "siliconmotion";
+ break;
diff --git a/xorg-server-hwcursor-gamma/xvfb-run b/xorg-server-hwcursor-gamma/xvfb-run
new file mode 100644
index 0000000..4c2f4e0
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/xvfb-run
@@ -0,0 +1,180 @@
+#!/bin/sh
+
+# $Id: xvfb-run 2027 2004-11-16 14:54:16Z branden $
+
+# This script starts an instance of Xvfb, the "fake" X server, runs a command
+# with that server available, and kills the X server when done. The return
+# value of the command becomes the return value of this script.
+#
+# If anyone is using this to build a Debian package, make sure the package
+# Build-Depends on xvfb, xbase-clients, and xfonts-base.
+
+set -e
+
+PROGNAME=xvfb-run
+SERVERNUM=99
+AUTHFILE=
+ERRORFILE=/dev/null
+STARTWAIT=3
+XVFBARGS="-screen 0 640x480x8"
+LISTENTCP="-nolisten tcp"
+XAUTHPROTO=.
+
+# Query the terminal to establish a default number of columns to use for
+# displaying messages to the user. This is used only as a fallback in the event
+# the COLUMNS variable is not set. ($COLUMNS can react to SIGWINCH while the
+# script is running, and this cannot, only being calculated once.)
+DEFCOLUMNS=$(stty size 2>/dev/null | awk '{print $2}') || true
+if ! expr "$DEFCOLUMNS" : "[[:digit:]]\+$" >/dev/null 2>&1; then
+ DEFCOLUMNS=80
+fi
+
+# Display a message, wrapping lines at the terminal width.
+message () {
+ echo "$PROGNAME: $*" | fmt -t -w ${COLUMNS:-$DEFCOLUMNS}
+}
+
+# Display an error message.
+error () {
+ message "error: $*" >&2
+}
+
+# Display a usage message.
+usage () {
+ if [ -n "$*" ]; then
+ message "usage error: $*"
+ fi
+ cat <<EOF
+Usage: $PROGNAME [OPTION ...] COMMAND
+Run COMMAND (usually an X client) in a virtual X server environment.
+Options:
+-a --auto-servernum try to get a free server number, starting at
+ --server-num
+-e FILE --error-file=FILE file used to store xauth errors and Xvfb
+ output (default: $ERRORFILE)
+-f FILE --auth-file=FILE file used to store auth cookie
+ (default: ./.Xauthority)
+-h --help display this usage message and exit
+-n NUM --server-num=NUM server number to use (default: $SERVERNUM)
+-l --listen-tcp enable TCP port listening in the X server
+-p PROTO --xauth-protocol=PROTO X authority protocol name to use
+ (default: xauth command's default)
+-s ARGS --server-args=ARGS arguments (other than server number and
+ "-nolisten tcp") to pass to the Xvfb server
+ (default: "$XVFBARGS")
+-w DELAY --wait=DELAY delay in seconds to wait for Xvfb to start
+ before running COMMAND (default: $STARTWAIT)
+EOF
+}
+
+# Find a free server number by looking at .X*-lock files in /tmp.
+find_free_servernum() {
+ # Sadly, the "local" keyword is not POSIX. Leave the next line commented in
+ # the hope Debian Policy eventually changes to allow it in /bin/sh scripts
+ # anyway.
+ #local i
+
+ i=$SERVERNUM
+ while [ -f /tmp/.X$i-lock ]; do
+ i=$(($i + 1))
+ done
+ echo $i
+}
+
+# Clean up files
+clean_up() {
+ if [ -e "$AUTHFILE" ]; then
+ XAUTHORITY=$AUTHFILE xauth remove ":$SERVERNUM" >>"$ERRORFILE" 2>&1
+ fi
+ if [ -n "$XVFB_RUN_TMPDIR" ]; then
+ if ! rm -r "$XVFB_RUN_TMPDIR"; then
+ error "problem while cleaning up temporary directory"
+ exit 5
+ fi
+ fi
+}
+
+# Parse the command line.
+ARGS=$(getopt --options +ae:f:hn:lp:s:w: \
+ --long auto-servernum,error-file:,auth-file:,help,server-num:,listen-tcp,xauth-protocol:,server-args:,wait: \
+ --name "$PROGNAME" -- "$@")
+GETOPT_STATUS=$?
+
+if [ $GETOPT_STATUS -ne 0 ]; then
+ error "internal error; getopt exited with status $GETOPT_STATUS"
+ exit 6
+fi
+
+eval set -- "$ARGS"
+
+while :; do
+ case "$1" in
+ -a|--auto-servernum) SERVERNUM=$(find_free_servernum) ;;
+ -e|--error-file) ERRORFILE="$2"; shift ;;
+ -f|--auth-file) AUTHFILE="$2"; shift ;;
+ -h|--help) SHOWHELP="yes" ;;
+ -n|--server-num) SERVERNUM="$2"; shift ;;
+ -l|--listen-tcp) LISTENTCP="" ;;
+ -p|--xauth-protocol) XAUTHPROTO="$2"; shift ;;
+ -s|--server-args) XVFBARGS="$2"; shift ;;
+ -w|--wait) STARTWAIT="$2"; shift ;;
+ --) shift; break ;;
+ *) error "internal error; getopt permitted \"$1\" unexpectedly"
+ exit 6
+ ;;
+ esac
+ shift
+done
+
+if [ "$SHOWHELP" ]; then
+ usage
+ exit 0
+fi
+
+if [ -z "$*" ]; then
+ usage "need a command to run" >&2
+ exit 2
+fi
+
+if ! which xauth >/dev/null; then
+ error "xauth command not found"
+ exit 3
+fi
+
+# tidy up after ourselves
+trap clean_up EXIT
+
+# If the user did not specify an X authorization file to use, set up a temporary
+# directory to house one.
+if [ -z "$AUTHFILE" ]; then
+ XVFB_RUN_TMPDIR="$(mktemp -d -t $PROGNAME.XXXXXX)"
+ AUTHFILE="$XVFB_RUN_TMPDIR/Xauthority"
+fi
+
+# Start Xvfb.
+MCOOKIE=$(mcookie)
+XAUTHORITY=$AUTHFILE xauth source - << EOF >>"$ERRORFILE" 2>&1
+add :$SERVERNUM $XAUTHPROTO $MCOOKIE
+EOF
+XAUTHORITY=$AUTHFILE Xvfb ":$SERVERNUM" $XVFBARGS $LISTENTCP >>"$ERRORFILE" \
+ 2>&1 &
+XVFBPID=$!
+sleep "$STARTWAIT"
+if ! kill -0 $XVFBPID 2>/dev/null; then
+ echo "Xvfb failed to start" >&2
+ exit 1
+fi
+
+# Start the command and save its exit status.
+set +e
+DISPLAY=:$SERVERNUM XAUTHORITY=$AUTHFILE "$@" 2>&1
+RETVAL=$?
+set -e
+
+# Kill Xvfb now that the command has exited.
+kill $XVFBPID
+
+# Return the executed command's exit status.
+exit $RETVAL
+
+# vim:set ai et sts=4 sw=4 tw=80:
diff --git a/xorg-server-hwcursor-gamma/xvfb-run.1 b/xorg-server-hwcursor-gamma/xvfb-run.1
new file mode 100644
index 0000000..137d3a1
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/xvfb-run.1
@@ -0,0 +1,282 @@
+.\" $Id: xvfb-run.1 2138 2005-01-17 23:40:27Z branden $
+.\"
+.\" Copyright 1998-2004 Branden Robinson <branden@debian.org>.
+.\"
+.\" This is free software; you may redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as
+.\" published by the Free Software Foundation; either version 2,
+.\" or (at your option) any later version.
+.\"
+.\" This is distributed in the hope that it will be useful, but
+.\" WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License with
+.\" the Debian operating system, in /usr/share/common-licenses/GPL; if
+.\" not, write to the Free Software Foundation, Inc., 59 Temple Place,
+.\" Suite 330, Boston, MA 02111-1307 USA
+.\"
+.\" We need the URL macro from groff's www macro package, but also want
+.\" things to work all right for people who don't have it. So we define
+.\" our own URL macro and let the www macro package override it if it's
+.\" available.
+.de URL
+\\$2 \(laURL: \\$1 \(ra\\$3
+..
+.if \n[.g] .mso www.tmac
+.TH xvfb\-run 1 "2004\-11\-12" "Debian Project"
+.SH NAME
+xvfb\-run \- run specified X client or command in a virtual X server environment
+.SH SYNOPSIS
+.B xvfb\-run
+[
+.I options
+]
+.I command
+.SH DESCRIPTION
+.B xvfb\-run
+is a wrapper for the
+.BR Xvfb (1x)
+command which simplifies the task of running commands (typically an X
+client, or a script containing a list of clients to be run) within a virtual
+X server environment.
+.PP
+.B xvfb\-run
+sets up an X authority file (or uses an existing user\-specified one),
+writes a cookie to it (see
+.BR xauth (1x))
+and then starts the
+.B Xvfb
+X server as a background process.
+The process ID of
+.B Xvfb
+is stored for later use.
+The specified
+.I command
+is then run using the X display corresponding to the
+.B Xvfb
+server
+just started and the X authority file created earlier.
+.PP
+When the
+.I command
+exits, its status is saved, the
+.B Xvfb
+server is killed (using the process ID stored earlier), the X authority
+cookie removed, and the authority file deleted (if the user did not specify
+one to use).
+.B xvfb\-run
+then exits with the exit status of
+.IR command .
+.PP
+.B xvfb\-run
+requires the
+.B xauth
+command to function.
+.SH OPTIONS
+.TP
+.B \-a\fR,\fB \-\-auto\-servernum
+Try to get a free server number, starting at 99, or the argument to
+.BR \-\-server\-num .
+.TP
+.BI \-e\ file \fR,\fB\ \-\-error\-file= file
+Store output from
+.B xauth
+and
+.B Xvfb
+in
+.IR file .
+The default is
+.IR /dev/null .
+.TP
+.BI \-f\ file \fR,\fB\ \-\-auth\-file= file
+Store X authentication data in
+.IR file .
+By default, a temporary directory called
+.IR xvfb\-run. PID
+(where PID is the process ID of
+.B xvfb\-run
+itself) is created in the directory specified by the environment variable
+.B TMPDIR
+(or
+.I /tmp
+if that variable is null or unset), and the
+.BR tempfile (1)
+command is used to create a file in that temporary directory called
+.IR Xauthority .
+.TP
+.B \-h\fR,\fB \-\-help
+Display a usage message and exit.
+.TP
+.BI \-n\ servernumber \fR,\fB\ \-\-server\-num= servernumber
+Use
+.I servernumber
+as the server number (but see the
+.B \-a\fR,\fB \-\-auto\-servernum
+option above).
+The default is 99.
+.TP
+.B \-l\fR,\fB \-\-listen\-tcp
+Enable TCP port listening in the X server.
+For security reasons (to avoid denial\-of\-service attacks or exploits),
+TCP port listening is disabled by default.
+.TP
+.BI \-p\ protocolname \fR,\fB\ \-\-xauth\-protocol= protocolname
+Use
+.I protocolname
+as the X authority protocol to use.
+The default is \(oq.\(cq, which
+.B xauth
+interprets as its own default protocol, which is MIT\-MAGIC\-COOKIE\-1.
+.TP
+.BI \-s\ arguments \fR,\fB\ \-\-server\-args= arguments
+Pass
+.I arguments
+to the
+.B Xvfb
+server.
+Be careful to quote any whitespace characters that may occur within
+.I arguments
+to prevent them from regarded as separators for
+.BR xvfb\-run 's
+own arguments.
+Also, note that specification of \(oq\-nolisten tcp\(cq in
+.I arguments
+may override the function of
+.BR xvfb\-run 's
+own
+.B \-l\fR,\fB \-\-listen\-tcp
+option, and that specification of the server number (e.g., \(oq:1\(cq) may
+be ignored because of the way the X server parses its argument list.
+Use the
+.B xvfb\-run
+option
+.BI \-n\ servernumber \fR,\fB\ \-\-server\-num= servernumber
+to achieve the latter function.
+The default is \(oq\-screen 0 640x480x8\(cq.
+.TP
+.BI \-w\ delay \fR,\fB\ \-\-wait= delay
+Wait
+.I delay
+seconds after launching
+.B Xvfb
+before attempting to start the specified command.
+The default is 3.
+.SH ENVIRONMENT
+.TP
+.B COLUMNS
+indicates the width of the terminal device in character cells.
+This value is used for formatting diagnostic messages.
+If not set, the terminal is queried using
+.BR stty (1)
+to determine its width.
+If that fails, a value of \(oq80\(cq is assumed.
+.TP
+.B TMPDIR
+specifies the directory in which to place
+.BR xvfb\-run 's
+temporary directory for storage of the X authority file; only used if the
+.B \-f
+or
+.B \-\-auth\-file
+options are not specified.
+.SH "OUTPUT FILES"
+.PP
+Unless the
+.B \-f
+or
+.B \-\-auth\-file
+options are specified, a temporary
+directory and file within it are created (and deleted) to store the X
+authority cookies used by the
+.B Xvfb
+server and client(s) run under it.
+See
+.BR tempfile (1).
+If \-f or \-\-auth\-file are used, then the specified X authority file is
+only written to, not created or deleted (though
+.B xauth
+creates an authority file itself if told to use use that does not already
+exist).
+.PP
+An error file with a user\-specified name is also created if the
+.B \-e
+or
+.B \-\-error\-file
+options are specifed; see above.
+.SH "EXIT STATUS"
+.B xvfb\-run
+uses its exit status as well as output to standard error to communicate
+diagnostics.
+The exit status of \(oq1\(cq is not used, and should be interpreted as failure
+of the specified command.
+.TP
+0
+.B xvfb\-run
+only uses this exit status if the
+.B \-h\fR,\fB \-\-help
+option is given.
+In all other situations, this may be interpreted as success of the specified
+command.
+.TP
+2
+No command to run was specified.
+.TP
+3
+The
+.B xauth
+command is not available.
+.TP
+4
+The temporary directory that was going to be used already exists; since
+.B xvfb\-run
+produces a uniquely named directory, this may indicate an attempt by another
+process on the system to exploit a temporary file race condition.
+.TP
+5
+A problem was encountered while cleaning up the temporary directory.
+.TP
+6
+A problem was encountered while using
+.BR getopt (1)
+to parse the command\-line arguments.
+.SH EXAMPLES
+.TP
+.B xvfb\-run \-\-auto\-servernum \-\-server\-num=1 xlogo
+runs the
+.BR xlogo (1x)
+demonstration client inside the
+.B Xvfb
+X server on the first available server number greater than or equal to 1.
+.TP
+.B xvfb\-run \-\-server\-args="\-screen 0 1024x768x24" ico \-faces
+runs the
+.BR ico (1x)
+demonstration client (and passes it the
+.B \-faces
+argument) inside the
+.B Xvfb
+X server, configured with a root window of 1024 by 768 pixels and a color
+depth of 24 bits.
+.PP
+Note that the demo X clients used in the above examples will not exit on
+their own, so they will have to be killed before
+.B xvfb\-run
+will exit.
+.SH BUGS
+See
+.URL "http://bugs.debian.org/xvfb" "the Debian Bug Tracking System" .
+If you wish to report a bug in
+.BR xvfb\-run ,
+please use the
+.BR reportbug (1)
+command.
+.SH AUTHOR
+.B xfvb\-run
+was written by Branden Robinson and Jeff Licquia with sponsorship from
+Progeny Linux Systems.
+.SH "SEE ALSO"
+.BR Xvfb (1x),
+.BR xauth (1x)
+.\" vim:set et tw=80: