aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2021-04-15 15:38:32 +0200
committerMattias Andrée <maandree@kth.se>2021-04-15 15:38:32 +0200
commit92e9cfbf7e1708a4a5289985ff92787a60e5ba9f (patch)
tree655ae0d3cbae6d20c57ad9919879c1c3cb199e0f
parentFix description for libterminput (diff)
downloadaur-packages-92e9cfbf7e1708a4a5289985ff92787a60e5ba9f.tar.gz
aur-packages-92e9cfbf7e1708a4a5289985ff92787a60e5ba9f.tar.bz2
aur-packages-92e9cfbf7e1708a4a5289985ff92787a60e5ba9f.tar.xz
Add libcontacts
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--libcontacts/PKGBUILD29
l---------libcontacts/upload1
2 files changed, 30 insertions, 0 deletions
diff --git a/libcontacts/PKGBUILD b/libcontacts/PKGBUILD
new file mode 100644
index 0000000..abc248e
--- /dev/null
+++ b/libcontacts/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libcontacts
+pkgver=1.0
+pkgrel=1
+pkgdesc="A library for handling a simple, flexible contact list"
+arch=(x86_64)
+url="https://github.com/maandree/libcontacts"
+license=('custom:ISC')
+depends=()
+checkdepends=()
+makedepends=()
+source=(libcontacts-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(208696e963157ef48fe517a83904ff0e860d2a0c2be8455dd85be2b96bff71d0)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/libcontacts/upload b/libcontacts/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libcontacts/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file