aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-11-16 23:20:25 +0100
committerMattias Andrée <maandree@kth.se>2016-11-16 23:20:25 +0100
commit7d2ad0bd91218fca6b771f0a00cf0f7ef674c523 (patch)
tree24a662d10c3bad59f271958c4cca492ef5194904
parentupdate rmixer (diff)
downloadaur-packages-7d2ad0bd91218fca6b771f0a00cf0f7ef674c523.tar.gz
aur-packages-7d2ad0bd91218fca6b771f0a00cf0f7ef674c523.tar.bz2
aur-packages-7d2ad0bd91218fca6b771f0a00cf0f7ef674c523.tar.xz
add bootcleanse
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--bootcleanse/PKGBUILD25
l---------bootcleanse/upload1
2 files changed, 26 insertions, 0 deletions
diff --git a/bootcleanse/PKGBUILD b/bootcleanse/PKGBUILD
new file mode 100644
index 0000000..383c64e
--- /dev/null
+++ b/bootcleanse/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=bootcleanse
+pkgver=2
+pkgrel=1
+pkgdesc='Cleanse your system from old MBR codes and boot flags'
+arch=(any)
+url='https://github.com/maandree/bootcleanse'
+license=(GPL3)
+depends=(python3 sudo sh coreutils)
+makedepends=(texinfo gzip)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(aed2f962a8b337263bfcc1aa215fc875babb1d5713143a9887d4cf8c3194b179)
+
+
+build() {
+ cd "$srcdir/bootcleanse-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/bootcleanse-$pkgver"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/bootcleanse/upload b/bootcleanse/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/bootcleanse/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file