aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2022-07-21 18:14:02 +0200
committerMattias Andrée <maandree@kth.se>2022-07-21 18:14:02 +0200
commit746a0b8bedb47ae8a095a204e84f4d9ecbda4bed (patch)
treec2328d30f978b7a34a069bc8e1f2ee3ef00a3462
parentAdd jlibgamma (diff)
downloadaur-packages-746a0b8bedb47ae8a095a204e84f4d9ecbda4bed.tar.gz
aur-packages-746a0b8bedb47ae8a095a204e84f4d9ecbda4bed.tar.bz2
aur-packages-746a0b8bedb47ae8a095a204e84f4d9ecbda4bed.tar.xz
Update packages
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--libgammamm/PKGBUILD26
l---------libgammamm/upload1
-rw-r--r--pylibgamma/PKGBUILD17
3 files changed, 35 insertions, 9 deletions
diff --git a/libgammamm/PKGBUILD b/libgammamm/PKGBUILD
new file mode 100644
index 0000000..1bbe978
--- /dev/null
+++ b/libgammamm/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libgammamm
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Display server abstraction layer for gamma ramps and C++"
+arch=(i686 x86_64)
+url="https://codeberg.org/maandree/libgammamm"
+license=('custom:ISC')
+depends=('libgamma>=0.3' glibc gcc-libs)
+makedepends=('libgamma>=0.3' glibc gcc-libs gcc make coreutils)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(999f7ec89769a6e2b6894b2dee7e2160c97dd473820bce5b2bf8a68a6f4eda1f)
+
+
+build() {
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr install DESTDIR="$pkgdir"
+}
+
diff --git a/libgammamm/upload b/libgammamm/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libgammamm/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/pylibgamma/PKGBUILD b/pylibgamma/PKGBUILD
index 268d18e..6444843 100644
--- a/pylibgamma/PKGBUILD
+++ b/pylibgamma/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
pkgname=pylibgamma
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
pkgdesc="Display server abstraction layer for gamma ramps and Python 3"
arch=(i686 x86_64)
-url="https://github.com/maandree/pylibgamma"
-license=('GPL3')
+url="https://codeberg.org/maandree/pylibgamma"
+license=('custom:ISC')
depends=(python3 'libgamma>=0.6' glibc)
makedepends=(python3 'libgamma>=0.6' glibc make gcc cython coreutils pkg-config)
-source=($url/archive/$pkgver.tar.gz)
-sha256sums=(e40f1291712e799d28eb4b4c5df9fe6b07ce5f0bf39bcd7f9416fb9d3335fb9a)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(09b4225384e5d8d0d55323b97d57ec435326275f935e41097eddbc9953c4bb33)
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
}
-