aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2019-02-10 21:05:25 +0100
committerMattias Andrée <maandree@kth.se>2019-02-10 21:05:25 +0100
commit49df00e528fd1a863d2f33373b5926cb210e6016 (patch)
tree98e4f17273c6aef331418c55cb0c49cfb9cff8fc
parentUpdate libkeccak (diff)
downloadaur-packages-49df00e528fd1a863d2f33373b5926cb210e6016.tar.gz
aur-packages-49df00e528fd1a863d2f33373b5926cb210e6016.tar.bz2
aur-packages-49df00e528fd1a863d2f33373b5926cb210e6016.tar.xz
...
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--libsha1/PKGBUILD29
l---------libsha1/upload1
-rw-r--r--libsha2/PKGBUILD29
l---------libsha2/upload1
-rw-r--r--simple-icon-theme/PKGBUILD4
5 files changed, 62 insertions, 2 deletions
diff --git a/libsha1/PKGBUILD b/libsha1/PKGBUILD
new file mode 100644
index 0000000..2a0de0b
--- /dev/null
+++ b/libsha1/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libsha1
+pkgver=1.0
+pkgrel=1
+pkgdesc="SHA-1 and SHA-0 hashing library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libsha1"
+license=('custom:ISC')
+depends=()
+checkdepends=()
+makedepends=()
+source=(libsha1-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(94b9de0edde7a922bb96ccc3585f06b9d9bce0adc0261bfd4e19048544782825)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/libsha1/upload b/libsha1/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libsha1/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/libsha2/PKGBUILD b/libsha2/PKGBUILD
new file mode 100644
index 0000000..aac0ee7
--- /dev/null
+++ b/libsha2/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libsha2
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="SHA-2-family hashing library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libsha2"
+license=('custom:ISC')
+depends=()
+checkdepends=()
+makedepends=()
+source=(libsha2-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(61601acb20e1e48161672783b851c12542c812b38b439bdc3615f22fbb2ef755)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/libsha2/upload b/libsha2/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libsha2/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/simple-icon-theme/PKGBUILD b/simple-icon-theme/PKGBUILD
index 706fd06..203f250 100644
--- a/simple-icon-theme/PKGBUILD
+++ b/simple-icon-theme/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
pkgname=simple-icon-theme
-pkgver=4
+pkgver=5
pkgrel=1
pkgdesc='A very simple icon theme'
url='https://github.com/maandree/simple-icon-theme'
@@ -10,7 +10,7 @@ license=('custom:ISC')
depends=(gtk-update-icon-cache)
makedepends=(librsvg)
source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-sha512sums=(5004dea5b1de1c4286cb378f1f494476db011936d325caa29ae0aa725ecb4534e29997df3b750afbcff4c0d0f115a39d321d1bd0d7b8707ecfacd76d8672d58f)
+sha512sums=(2d98383c88990ee95779e3f120f406fcc838378092bd62b883ce5b7be398d5ed04af21ac10cc0ef9db7afa5d072ee69333078ce0a3c553714bbee8439e6bcedf)
build () {
cd "$srcdir/simple-icon-theme-$pkgver"