aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2015-01-19 06:44:37 +0100
committerMattias Andrée <maandree@operamail.com>2015-01-19 06:44:37 +0100
commit411f14a8f4ace9a7f5aa455fa90c0608e0a1317a (patch)
treeaeff1cd02167e9b29d3132070ff4d5c35036cddd
parentupdate dooble (diff)
downloadaur-packages-411f14a8f4ace9a7f5aa455fa90c0608e0a1317a.tar.gz
aur-packages-411f14a8f4ace9a7f5aa455fa90c0608e0a1317a.tar.bz2
aur-packages-411f14a8f4ace9a7f5aa455fa90c0608e0a1317a.tar.xz
update emacs-gtk2
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to '')
-rw-r--r--emacs-gtk2/PKGBUILD13
-rw-r--r--emacs-gtk2/gnupg21.patch28
2 files changed, 38 insertions, 3 deletions
diff --git a/emacs-gtk2/PKGBUILD b/emacs-gtk2/PKGBUILD
index 68e3333..ea97ba2 100644
--- a/emacs-gtk2/PKGBUILD
+++ b/emacs-gtk2/PKGBUILD
@@ -5,18 +5,25 @@
_pkgname=emacs
pkgname=$_pkgname-gtk2
pkgver=24.4
-pkgrel=1
+pkgrel=2
pkgdesc="The extensible, customizable, self-documenting real-time display editor. GTK2 version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk2' 'hicolor-icon-theme' 'desktop-file-utils' 'alsa-lib' 'imagemagick>=6.8.4.7')
install=emacs-gtk2.install
-source=(ftp://ftp.gnu.org/gnu/emacs/$_pkgname-$pkgver.tar.xz{,.sig})
-md5sums=('ad487658ad7421ad8d7b5152192eb945' 'SKIP')
+source=(ftp://ftp.gnu.org/gnu/emacs/$_pkgname-$pkgver.tar.xz{,.sig}
+ gnupg21.patch)
+md5sums=('ad487658ad7421ad8d7b5152192eb945'
+ 'SKIP'
+ '0583d868e0e304bac3df95b7518615cd')
provides=('emacs')
conflicts=('emacs')
+prepare() {
+ cd "$srcdir"/emacs-$pkgver
+ patch -p1 -i ../gnupg21.patch
+}
build() {
cd "$srcdir"/emacs-$pkgver
diff --git a/emacs-gtk2/gnupg21.patch b/emacs-gtk2/gnupg21.patch
new file mode 100644
index 0000000..bbac3d9
--- /dev/null
+++ b/emacs-gtk2/gnupg21.patch
@@ -0,0 +1,28 @@
+From 135a9f4b5aead507c030fb7e3e8ad13aaa91f403 Mon Sep 17 00:00:00 2001
+From: Daiki Ueno <ueno@gnu.org>
+Date: Fri, 07 Nov 2014 02:31:12 +0000
+Subject: epg: Adjust to GnuPG 2.1 key listing change
+
+* epg.el (epg--list-keys-1): Ignore fields after the 15th field
+(bug#18979). Reported by Hideki Saito.
+---
+(limited to 'lisp/epg.el')
+
+diff --git a/lisp/epg.el b/lisp/epg.el
+index 0c74531..e4d8c1e 100644
+--- a/lisp/epg.el
++++ b/lisp/epg.el
+@@ -1278,8 +1278,9 @@ callback data (if any)."
+ string (match-string 0)
+ index 0
+ field 0)
+- (while (eq index
+- (string-match "\\([^:]+\\)?:" string index))
++ (while (and (< field (length (car keys)))
++ (eq index
++ (string-match "\\([^:]+\\)?:" string index)))
+ (setq index (match-end 0))
+ (aset (car keys) field (match-string 1 string))
+ (setq field (1+ field))))
+--
+cgit v0.9.0.2