aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhil Blundell <pb@reciva.com>2004-03-25 23:57:55 +0000
committerPhil Blundell <pb@reciva.com>2004-03-25 23:57:55 +0000
commit5025a4ed4ca1d47449d7b8164f985d48766be29d (patch)
tree68d2d55aec8ed1d5613720a0e4007d9f46b34d0a /configure.ac
parentTrack whether cliplists have changed and avoid computation when not. Shrink (diff)
downloadxcman-5025a4ed4ca1d47449d7b8164f985d48766be29d.tar.gz
xcman-5025a4ed4ca1d47449d7b8164f985d48766be29d.tar.bz2
xcman-5025a4ed4ca1d47449d7b8164f985d48766be29d.tar.xz
Autotoolized:
New files. Likewise. Deleted.
Diffstat (limited to '')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..171ccf6
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
+AC_CONFIG_SRCDIR([xcompmgr.c])
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+AC_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_TIME
+AC_STRUCT_TM
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([gettimeofday localtime_r])
+
+PKG_CHECK_MODULES(XCOMPMGR, xcomposite xfixes xdamage xrender)
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT