aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@linux.ie>2006-12-21 18:36:08 +1100
committerDave Airlie <airlied@linux.ie>2006-12-21 18:36:08 +1100
commit340f74b2180fafd3b851e85c501bdc34ce64795c (patch)
treeb0e51a6e56306cd53ad9579ac15a379e36b55d22 /Makefile.am
parentBug #2703: Fixed a memory leak in the fading code. (diff)
downloadxcman-340f74b2180fafd3b851e85c501bdc34ce64795c.tar.gz
xcman-340f74b2180fafd3b851e85c501bdc34ce64795c.tar.bz2
xcman-340f74b2180fafd3b851e85c501bdc34ce64795c.tar.xz
remove changelog from xcompmgr
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cee043d..e5377f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,4 +7,16 @@ INCLUDES = @XCOMPMGR_CFLAGS@
EXTRA_DIST = \
autogen.sh \
+ ChangeLog \
${man_MANS}
+
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not
+found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+