aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-19 19:49:37 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-19 19:49:37 -0200
commit58d299e54e1198bfa64c39e49c2c0020f9f62b98 (patch)
treeac7c6a04f1ad44dca02adf18943bb16b152631a5 /Makefile.am
parentMake usage() report the current version. (diff)
downloadxcman-58d299e54e1198bfa64c39e49c2c0020f9f62b98.tar.gz
xcman-58d299e54e1198bfa64c39e49c2c0020f9f62b98.tar.bz2
xcman-58d299e54e1198bfa64c39e49c2c0020f9f62b98.tar.xz
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and all gcc 4.3 and sparse warnings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4bc0ba3..3884d94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,8 @@
bin_PROGRAMS = xcompmgr
man_MANS = xcompmgr.1
-xcompmgr_LDADD = @XCOMPMGR_LIBS@ -lm
-
-INCLUDES = @XCOMPMGR_CFLAGS@
+AM_CFLAGS = $(XCOMPMGR_CFLAGS)
+xcompmgr_LDADD = $(XCOMPMGR_LIBS) -lm
EXTRA_DIST = \
autogen.sh \
@@ -15,7 +14,7 @@ MAINTAINERCLEANFILES=ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog