aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c07aea3..6c4a613 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,17 +9,19 @@ INCLUDES = -DLOCALEDIR=\"$(localedir)\"
bin_PROGRAMS = redshift
redshift_SOURCES = \
- redshift.c \
+ redshift.c redshift.h \
colorramp.c colorramp.h \
+ config-ini.c config-ini.h \
+ location-manual.c location-manual.h \
solar.c solar.h \
- systemtime.c systemtime.h \
- location-manual.c location-manual.h
+ systemtime.c systemtime.h
EXTRA_redshift_SOURCES = \
gamma-randr.c gamma-randr.h \
gamma-vidmode.c gamma-vidmode.h \
gamma-w32gdi.c gamma-w32gdi.h \
- location-gnome-clock.c location-gnome-clock.h
+ location-gnome-clock.c location-gnome-clock.h \
+ location-geoclue.c location-geoclue.h
AM_CFLAGS =
redshift_LDADD = @LIBINTL@
@@ -53,3 +55,10 @@ redshift_LDADD += \
$(GLIB_LIBS) $(GLIB_CFLAGS) \
$(GCONF_LIBS) $(GCONF_CFLAGS)
endif
+
+if ENABLE_GEOCLUE
+redshift_SOURCES += location-geoclue.c location-geoclue.h
+AM_CFLAGS += $(GEOCLUE_CFLAGS) $(GEOCLUE_LIBS)
+redshift_LDADD += \
+ $(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
+endif