aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 318fc2c..99c8a2e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,15 +9,16 @@ AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
bin_PROGRAMS = redshift
redshift_SOURCES = \
- redshift.c redshift.h \
- signals.c signals.h \
colorramp.c colorramp.h \
config-ini.c config-ini.h \
+ gamma-dummy.c gamma-dummy.h \
+ hooks.c hooks.h \
location-manual.c location-manual.h \
+ pipeutils.c pipeutils.h \
+ redshift.c redshift.h \
+ signals.c signals.h \
solar.c solar.h \
- systemtime.c systemtime.h \
- hooks.c hooks.h \
- gamma-dummy.c gamma-dummy.h
+ systemtime.c systemtime.h
EXTRA_redshift_SOURCES = \
gamma-drm.c gamma-drm.h \
@@ -25,11 +26,14 @@ EXTRA_redshift_SOURCES = \
gamma-vidmode.c gamma-vidmode.h \
gamma-quartz.c gamma-quartz.h \
gamma-w32gdi.c gamma-w32gdi.h \
- location-geoclue.c location-geoclue.h
+ location-geoclue2.c location-geoclue2.h \
+ location-corelocation.m location-corelocation.h \
+ windows/appicon.rc \
+ windows/versioninfo.rc
AM_CFLAGS =
redshift_LDADD = @LIBINTL@
-EXTRA_DIST =
+EXTRA_DIST = windows/redshift.ico
if ENABLE_DRM
redshift_SOURCES += gamma-drm.c gamma-drm.h
@@ -67,16 +71,6 @@ redshift_LDADD += -lgdi32
endif
-if ENABLE_GEOCLUE
-redshift_SOURCES += location-geoclue.c location-geoclue.h
-AM_CFLAGS += \
- $(GEOCLUE_CFLAGS) $(GEOCLUE_LIBS) \
- $(GLIB_CFLAGS) $(GLIB_LIBS)
-redshift_LDADD += \
- $(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
- $(GLIB_LIBS) $(GLIB_CFLAGS)
-endif
-
if ENABLE_GEOCLUE2
redshift_SOURCES += location-geoclue2.c location-geoclue2.h
AM_CFLAGS += \
@@ -99,3 +93,12 @@ liblocation_corelocation_la_LIBADD = \
$(CORELOCATION_CFLAGS) $(CORELOCATION_LIBS)
redshift_LDADD += liblocation-corelocation.la
endif
+
+
+# Windows resources
+if ENABLE_WINDOWS_RESOURCE
+redshift_SOURCES += windows/appicon.rc windows/versioninfo.rc
+endif
+
+.rc.o:
+ $(AM_V_GEN)$(WINDRES) -I$(top_builddir) -i $< -o $@