aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 18e2855..5a743ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,10 +78,15 @@ AC_ARG_ENABLE([gtk], [AC_HELP_STRING([--enable-gtk],
[enable GTK status icon])],
[enable_gtk=$enableval],[enable_gtk=maybe])
AS_IF([test "x$enable_gtk" != xno], [
- AS_IF([test $have_python != yes], [
- AC_MSG_WARN([status icon script requires Python and PyGTK])
+ AS_IF([test $have_python = yes], [
+ AC_MSG_RESULT([yes])
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_gtk" = xyes], [
+ AC_MSG_ERROR([status icon script requires Python 2.4])
+ ])
+ enable_gtk=no
])
- AC_MSG_RESULT([yes])
], [
AC_MSG_RESULT([no])
])