aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 39 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 18e2855..b2ee3a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.64])
-AC_INIT([redshift], [1.1], [https://bugs.launchpad.net/redshift])
+AC_INIT([redshift], [1.3], [https://bugs.launchpad.net/redshift])
AC_CONFIG_SRCDIR([src/redshift.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
@@ -20,8 +20,10 @@ PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
+AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
+
# Check for Python
-AM_PATH_PYTHON([2.4], [have_python=yes], [have_python=no])
+AM_PATH_PYTHON([2.6], [have_python=yes], [have_python=no])
# Check RANDR method
AC_MSG_CHECKING([whether to enable RANDR method])
@@ -67,9 +69,31 @@ AS_IF([test "x$enable_vidmode" != xno], [
])
AM_CONDITIONAL([ENABLE_VIDMODE], [test "x$enable_vidmode" != xno])
+# Check Windows GDI method
+AC_MSG_CHECKING([whether to enable WinGDI method])
+AC_ARG_ENABLE([wingdi], [AC_HELP_STRING([--enable-wingdi],
+ [enable WinGDI method])],
+ [enable_wingdi=$enableval],[enable_wingdi=maybe])
+AS_IF([test "x$enable_wingdi" != xno], [
+ AS_IF([test $have_windows_h = yes], [
+ AC_DEFINE([ENABLE_WINGDI], 1,
+ [Define to 1 to enable WinGDI method])
+ AC_MSG_RESULT([yes])
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_wingdi" = xyes], [
+ AC_MSG_ERROR([missing Windows API headers for WinGDI method])
+ ])
+ enable_wingdi=no
+ ])
+], [
+ AC_MSG_RESULT([no])
+])
+AM_CONDITIONAL([ENABLE_WINGDI], [test "x$enable_wingdi" != xno])
+
# Check that at least one method is enabled
-AS_IF([test "x$enable_randr" = xno -a "x$enable_vidmode" = xno], [
- AC_MSG_ERROR([either RANDR or VidMode must be enabled])
+AS_IF([test "x$enable_randr" = xno -a "x$enable_vidmode" = xno -a "x$enable_wingdi" = xno], [
+ AC_MSG_ERROR([either RANDR, VidMode or WinGDI must be enabled])
])
# Check for GTK+ status icon
@@ -78,23 +102,27 @@ AC_ARG_ENABLE([gtk], [AC_HELP_STRING([--enable-gtk],
[enable GTK status icon])],
[enable_gtk=$enableval],[enable_gtk=maybe])
AS_IF([test "x$enable_gtk" != xno], [
- AS_IF([test $have_python != yes], [
- AC_MSG_WARN([status icon script requires Python and PyGTK])
+ AS_IF([test $have_python = yes], [
+ AC_MSG_RESULT([yes])
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_gtk" = xyes], [
+ AC_MSG_ERROR([status icon script requires Python 2.6])
+ ])
+ enable_gtk=no
])
- AC_MSG_RESULT([yes])
], [
AC_MSG_RESULT([no])
])
AM_CONDITIONAL([ENABLE_GTK], [test "x$enable_gtk" != xno])
# Checks for header files.
-AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h])
+AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h sys/signal.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_UINT16_T
# Checks for library functions.
-AC_FUNC_MALLOC
AC_SEARCH_LIBS([clock_gettime], [rt])
AC_SEARCH_LIBS([floor], [m])
AC_CHECK_FUNCS([setlocale strchr floor pow clock_gettime])
@@ -102,6 +130,8 @@ AC_CHECK_FUNCS([setlocale strchr floor pow clock_gettime])
AC_CONFIG_FILES([
Makefile
po/Makefile.in
+ src/Makefile
+ src/gtk-redshift/Makefile
])
AC_OUTPUT