aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 22dd3e9..16aabf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.64])
-AC_INIT([redshift], [1.3], [https://bugs.launchpad.net/redshift])
+AC_INIT([redshift], [1.4], [https://bugs.launchpad.net/redshift])
AC_CONFIG_SRCDIR([src/redshift.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
@@ -22,7 +22,7 @@ PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
-PKG_CHECK_MODULES([GLIB], [glib-2.0], [have_glib=yes], [have_glib=no])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 gobject-2.0], [have_glib=yes], [have_glib=no])
PKG_CHECK_MODULES([GCONF], [gconf-2.0], [have_gconf=yes], [have_gconf=no])
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
@@ -141,22 +141,26 @@ AC_ARG_ENABLE([gui], [AC_HELP_STRING([--enable-gui],
[enable_gui=$enableval],[enable_gui=maybe])
# Statusicon GUI
-AS_IF([test "x$enable_gui" = xstatusicon -o "x$enable_gui" = maybe], [
- AS_IF([test $have_python != yes], [
+AS_IF([test "x$enable_gui" = xstatusicon -o "x$enable_gui" = xmaybe], [
+ AS_IF([test "x$have_python" != xyes], [
AS_IF([test "x$enable_gui" = xstatusicon], [
AC_MSG_ERROR([status icon script requires Python 2.6])
])
enable_gui=maybe
+ ], [
+ enable_gui=statusicon
])
])
# Appindicator GUI
-AS_IF([test "x$enable_gui" = xappindicator -o "x$enable_gui" = maybe], [
- AS_IF([test $have_python != yes], [
+AS_IF([test "x$enable_gui" = xappindicator -o "x$enable_gui" = xmaybe], [
+ AS_IF([test "x$have_python" != xyes], [
AS_IF([test "x$enable_gui" = xappindicator], [
AC_MSG_ERROR([application indicator script requires Python 2.6])
])
enable_gui=maybe
+ ], [
+ enable_gui=appindicator
])
])