aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-06-30 19:55:36 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2010-06-30 19:55:36 +0200
commit0d533f457c4053e3f8fb3a5c86d2c43689dd2b15 (patch)
treed6edf22c8b64f5336e233e411a20d57cd08bf0ef /src/gtk-redshift/Makefile.am
parentChange comment in colorramp.c. (diff)
parentutils.py: copy the desktop file in autostart folder (diff)
downloadredshift-ng-0d533f457c4053e3f8fb3a5c86d2c43689dd2b15.tar.gz
redshift-ng-0d533f457c4053e3f8fb3a5c86d2c43689dd2b15.tar.bz2
redshift-ng-0d533f457c4053e3f8fb3a5c86d2c43689dd2b15.tar.xz
Merge GUI autostart feature from Francesco Marella.
Diffstat (limited to '')
-rw-r--r--src/gtk-redshift/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index ddeafd6..42647f7 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -3,24 +3,34 @@ if ENABLE_STATUSICON
gui_module=statusicon
gtk_redshift_PYTHON = \
__init__.py \
+ utils.py \
statusicon.py
nodist_gtk_redshift_PYTHON = \
defs.py
gtk_redshiftdir = $(pythondir)/gtk_redshift
bin_SCRIPTS = gtk-redshift
+
+# Desktop file
+desktopdir = ${datadir}/applications
+desktop_DATA = gtk-redshift.desktop
endif
if ENABLE_APPINDICATOR
gui_module=rsappindicator
gtk_redshift_PYTHON = \
__init__.py \
+ utils.py \
rsappindicator.py
nodist_gtk_redshift_PYTHON = \
defs.py
gtk_redshiftdir = $(pythondir)/gtk_redshift
bin_SCRIPTS = gtk-redshift
+
+# Desktop file
+desktopdir = ${datadir}/applications
+desktop_DATA = gtk-redshift.desktop
endif
EXTRA_DIST = gtk-redshift.in \