aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2013-12-29 20:14:14 -0500
committerTingPing <tingping@tingping.se>2014-01-01 14:11:11 -0500
commitd7975feaea007f7e190a1c4cf2ad0d63fea4752f (patch)
tree79c0b1940d85f4b422aaf53d864bb6902f88c81a /Makefile.am
parentPort redshift-gtk to Python3 (diff)
downloadredshift-ng-d7975feaea007f7e190a1c4cf2ad0d63fea4752f.tar.gz
redshift-ng-d7975feaea007f7e190a1c4cf2ad0d63fea4752f.tar.bz2
redshift-ng-d7975feaea007f7e190a1c4cf2ad0d63fea4752f.tar.xz
Update icon cache on install
Diffstat (limited to '')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 000076f..f3109ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@
SUBDIRS = src po
ACLOCAL_AMFLAGS = -I m4
+UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
+
EXTRA_ROOTDOC_FILES = \
HACKING \
DESIGN \
@@ -45,6 +47,14 @@ desktopdir = @datadir@/applications
desktop_DATA = $(_DESKTOP_FILES)
endif
+if ENABLE_GUI
+install-data-hook:
+ $(UPDATE_ICON_CACHE);
+
+uninstall-hook:
+ $(UPDATE_ICON_CACHE);
+endif
+
# man page
dist_man1_MANS = redshift.1