summaryrefslogtreecommitdiffstats
path: root/dist/archlinux/stable/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2014-03-04 19:19:23 +0100
committerMattias Andrée <maandree@operamail.com>2014-03-04 19:19:23 +0100
commit90a18582123606c7ddf22c63574ddb0d89870513 (patch)
tree741f5a7a3bc60dadb4e39b209e15d10ec88a2d5f /dist/archlinux/stable/PKGBUILD
parentsmall example transitioning from current settings (diff)
downloadblueshift-90a18582123606c7ddf22c63574ddb0d89870513.tar.gz
blueshift-90a18582123606c7ddf22c63574ddb0d89870513.tar.bz2
blueshift-90a18582123606c7ddf22c63574ddb0d89870513.tar.xz
update dist
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to 'dist/archlinux/stable/PKGBUILD')
-rw-r--r--dist/archlinux/stable/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/dist/archlinux/stable/PKGBUILD b/dist/archlinux/stable/PKGBUILD
index a41af55..210d3c9 100644
--- a/dist/archlinux/stable/PKGBUILD
+++ b/dist/archlinux/stable/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=blueshift
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="An extensible and highly configurable alternative to redshift"
arch=(i686 x86_64)
url="https://github.com/maandree/blueshift"
license=('AGPL3')
-depends=(python3 libxcb argparser)
-makedepends=(cython gcc python3 libxcb make coreutils sed zip texinfo auto-auto-complete)
+depends=(python3 argparser libxcb libxxf86vm libx11)
+makedepends=(cython gcc python3 libxcb libxxf86vm libx11 make coreutils sed zip texinfo auto-auto-complete)
install=blueshift.install
source=($url/archive/$pkgver.tar.gz)
-sha256sums=('5df863bbdbbf6d49546266c0f6686eb8bf4bf595a9049932d6c816a260788d8f')
+sha256sums=('d6930a0c4c980d3c9f2f6ba081edd4e59158d750090383eb463e6c3d78474def')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ LDFLAGS=${LDFLAGS/--as-needed/}
+ LDFLAGS=${LDFLAGS/,,/,}
+ export LDFLAGS
make PREFIX=/usr LIBEXEC=/lib/blueshift
}